Problem: Getting Error: Version 1.6.0_24 of ther JVM is not suitable for this product. Version:1.7 or greater is required while working with Eclipse on Cloudera CDH3.

  

Solution:

Open the terminalà type the below commands.


Commands:

Syntax: cd /path/to/eclipse 

E.g: cd /home;/cloudera/eclipse


sudo gedit eclipse.ini

  


After opening the window change the Required java version to 1.6

  


After you should be able to open the Eclipse as in the below screenshot.


Please feel free to revert if you need any further help.